Author Topic: beeman falcon 1 not firing  (Read 7044 times)

Offline steyr223

  • Fledgling Prepper
  • *
  • Posts: 4
  • Karma: 0
  • New TSP Forum member
beeman falcon 1 not firing
« on: May 30, 2016, 05:39:28 AM »
Hey guys how's everybody
 I bought a Beeman Falcon 1 and I think I already figured out the problem I was reading the break barrel cocking hard and they said not to dry fire it
Not sure if mine uses the air spring thing ( sorry )

Everything was fine I took the stock off to modify when put back together the
Safety sear? Would stick over the trigger just enough to make it not able to pull so I put a tiny pin in the side to keep
It back out of the way
Everything seems to work fine except the pellet doesn't move at all

I can't find any diagrams to even begin to know if a part is missing or why.....

I guess I should come clean
I tried to mold a dart but the head was to big .I had to remove it with a steel rod ,it popped out very easily so I don't know if this caused the problem or not

Any info or manuals, diagrams,links would be greatly appreciated

Thanks steyr223 Rob

Offline steyr223

  • Fledgling Prepper
  • *
  • Posts: 4
  • Karma: 0
  • New TSP Forum member
Re: beeman falcon 1 not firing
« Reply #1 on: May 30, 2016, 05:34:21 PM »
Come on guys I know I'm a noob to this form
But........well .............can u even point me in the he right direction
I am dieing to play with this my stock modification came out really good
Which is rare for me anytime I touch wood
Thanks steyr223 rob

Offline never_retreat

  • Survivalist Mentor
  • *****
  • Posts: 928
  • Karma: 34
  • I am the Great Cornholio I need TP for my bunghole
Re: beeman falcon 1 not firing
« Reply #2 on: May 30, 2016, 06:50:35 PM »
It is a holiday and traffic is light today.
As much as I know about guns I know nothing about Spanish air rifles.

There is quite a lot of gun talk here, but you may need to go to an air rifle forum.

Offline 1greenman

  • Survivor
  • ***
  • Posts: 174
  • Karma: 4
  • New TSP Forum member
    • The Healthy Family Variety Channel
Re: beeman falcon 1 not firing
« Reply #3 on: May 30, 2016, 08:44:46 PM »
Ditto.  I know nothing of air rifles.

Love watching SQUIRREL HUNTER on youTube, and som South African chap, but know not a bit more than that.

Offline steyr223

  • Fledgling Prepper
  • *
  • Posts: 4
  • Karma: 0
  • New TSP Forum member
Re: beeman falcon 1 not firing
« Reply #4 on: May 31, 2016, 03:49:43 AM »
Thanks guys I thought this was an airgun board but I guess not a form dedicated to that just a side interest
Cool thanks for the tip I will look
Steyr223 Rob

Offline steyr223

  • Fledgling Prepper
  • *
  • Posts: 4
  • Karma: 0
  • New TSP Forum member
Re: beeman falcon 1 not firing
« Reply #5 on: June 02, 2016, 07:02:49 AM »
I tried a couple airgun forms
Still can't find an answer

I got the safety working correctly . there is a pin that goes across the barrel at the top above the
Firing area( trigger ) I think to hold it from sliding around so when a cocked it it just slid back .
Don't know how it just slid out nor how I found it ......but it still doesn't push the pellet out,everything els
Seems this work fine
Any ideas ,comments,suggestions would be appreciated
Thanks steyr223 Rob

Offline valley ranch

  • Prepper
  • **
  • Posts: 34
  • Karma: 1
  • New TSP Forum member
Re: beeman falcon 1 not firing
« Reply #6 on: October 18, 2016, 07:49:32 PM »
Hi, Just read your post. I have a beeman, trying to figure out what you are saying.

OK, in the trigger lope, the safety release is forward of the trigger. Are you saying it no longer comes of safety ? Another thing : Your home made pellet could have plugged the compressed air entry, have you checked that?

Richard

Offline Carl

  • Mr HamTastic!
  • Forum Veteran
  • *********
  • Posts: 13105
  • Karma: 716
  • COW?...No ,I haven't seen your cow.
Re: beeman falcon 1 not firing
« Reply #7 on: October 19, 2016, 04:34:02 AM »
I looked the mechanism up and the safety sear really should not be pinned ,it needs freedom of motion.
remove the pin that you put in and try again.